Jump to content


Photo

Feedback Re: Chapter 2


  • Please log in to reply
2 replies to this topic

#1 AZOTh999

AZOTh999

    New Member

  • Members
  • Pip
  • 2 posts

Posted 12 February 2013 - 07:37 PM

I personally ran into some snags and curve balls during chapter 2, specifically near the module creation areas. It turned out that the snag was a designed snag regarding the namespace, and that's fine; it's a method of reinforcing a learning technique. Its intended effect was probably achieved for Windows & MacOS users who were following right along in IDLE.

However, I'm doing this on a linux box, and the distro I'm using has python 2.x installed by default. While I got python 3.2 installed w/o issue, due to the 2.x being the standard build, I could not install IDLE 3.2 due to package conflicts. Rather than making a potential mess of my system libraries by grabbing tarballs and compiling to get IDLE, I just opted to run without it. Any time you mentioned IDLE, my "IDLE" was a terminal with python3.2 shell running on the bottom, and my editor was handy ole vim in a terminal above. Everything worked without a hitch up to this point.

Where the curve ball threw me off was when reference was made to running the nester module we created in the editor by hitting F5. I didn't have an equivalent of that, and really had no clue what F5 was supposed to do for the IDLE users at that point. I figured I'd drive on, as it was probably running the script, so I ran it from command line with no errors, but there is no way to test the functionality in this manner in the same fashion by testing the module success. But after making and installing my module distro, when I ran into the designed namespace snag, it actually kind of threw me through a loop. I went back and triple checked my code, tried alternate quoting/comment methods in the comments, whacked, ran setup again to reform the distro each time, reinstalled the distro each time... totally convinced that I'd missed something in my code that might've been uncovered in the F5 step if I'd had that functionaility. It wasn't until I'd cooled down a bit and had a cigarette or two that I'd picked up the book again and realized that I hadn't missed anything and was hitting a designed snag, and drove on into the namespace section.

So one suggestion I'd make in the next version, is to either:

a.) Lay out the groundwork for all of the potential OSs one might be working on (and linux is a major contender on the desktop these days... & most linux distros still run 2.x as a default install, as it is the stable release and a lot of the system packages will depend on that version). Maybe come up with an alternative version of examples like the F5 in IDLE as a sidebar note if per chance someone is not running IDLE 3.x for some reason (i.e. 3.x conflicts with 2.x, etc). else:

b.) figure out a means of presenting the material non-dependent of specific editor/IDE/OS, or get those snags out of the way earlier in the prelude so that all other chapter material can be mainly void of particular OS-dependent method except where necessary (filesystem/shell prompt, etc.).

Just some thoughts. That one snag really irritated me when I'd thought maybe I'd lost/missed something in the translation, and I'd lost a few hours to backtracking and double-checking & triple-checking my work unnecessarily. I hadn't, but I'd not progressed to the namespace section to explore that topic yet... just got stuck on the fail & distracted.

Other feedback: I don't want this to appear that I don't appreciate what all else you've had going on up to this point. Fresh approach on the methodology of presenting the material. Very engaging, and pretty (generally) fast-paced and rapid engagement of the material. But if you could find a way to maybe smooth out this potential snag, you could probably make this particular section flow more naturally for your other readers which might be in a similar boat and not be using IDLE 3.2 for similar reasons.

My two cents worth.

Have a great one, and thanks for your work on the book. It's been a rapid & engaging read thus far.

Edited by AZOTh999, 12 February 2013 - 07:41 PM.


#2 paulbarry

paulbarry

    Advanced Member

  • O'Reilly Author
  • PipPipPipPipPipPipPipPip
  • 307 posts

Posted 13 February 2013 - 03:16 AM

I'm working on the second edition right now. Thanks for these suggestions (which I'm considering). Regards.

--Paul.

#3 AZOTh999

AZOTh999

    New Member

  • Members
  • Pip
  • 2 posts

Posted 14 February 2013 - 08:48 PM

I'm working on the second edition right now. Thanks for these suggestions (which I'm considering). Regards.

--Paul.


Good evening, Paul.

In hindsight, the further away I get from the snag I experienced, the less significant it seems like it's likely to be to the bulk of your potential readers. There honestly may not be that many of the *nix users who are experiencing similar package conflict issues with being unable to install IDLE 3.x. While it may have thrown me through a loop of logic for a bit, that's not necessarily going to be the typical response, I imagine. Perhaps the structure is fine just the way that it is.

Thanks for the reply, regardless, Paul.

Have a good one!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users