O'Reilly Forums: Nothing Works On Windows 7 - O'Reilly Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Nothing Works On Windows 7 Many errors installing Apache & PHP

#1 User is offline   jose v 

  • New Member
  • Pip
  • Group: Members
  • Posts: 3
  • Joined: 16-May 12

Posted 16 May 2012 - 12:06 PM

The Apache and PHP files' versions in the book don't exist anymore and the current doesn't work on my W7.

Any idea?
0

#2 User is offline   drewdin 

  • Super Veteran Member
  • PipPipPipPipPipPipPipPipPipPipPip
  • Group: Members
  • Posts: 608
  • Joined: 11-February 10
  • Gender:Male
  • Location:Boston

Posted 16 May 2012 - 07:21 PM

View Postlemuel, on 16 May 2012 - 01:06 PM, said:

You can install everything you need in one package. Two of the more popular options:

XAMPP: http://www.apachefri...g/en/xampp.html
note this: http://www.apachefri...hp?f=16&t=50616

WAMP: http://www.wampserver.com/en/


my vote is for wamp!
0

#3 User is offline   jose v 

  • New Member
  • Pip
  • Group: Members
  • Posts: 3
  • Joined: 16-May 12

Posted 22 May 2012 - 06:10 PM

Thank you. I don't know perl and don't have linux so I installed the wamp package but when i click the desktop icon the window below pop-up.

It says something like that: "procedure entry point missed in the dynamic library"

I think I broke my W7 installing and uninstalling microsoft server versions, old apaches and phps.

Attached thumbnail(s)

  • Attached Image: error.jpg

This post has been edited by jose v: 22 May 2012 - 06:13 PM

0

#4 User is offline   drewdin 

  • Super Veteran Member
  • PipPipPipPipPipPipPipPipPipPipPip
  • Group: Members
  • Posts: 608
  • Joined: 11-February 10
  • Gender:Male
  • Location:Boston

Posted 23 May 2012 - 03:53 PM

I can't read what that says and I'm not sure what you did so it really hard to know what to tell you to fix. Sorry
0

#5 User is offline   jose v 

  • New Member
  • Pip
  • Group: Members
  • Posts: 3
  • Joined: 16-May 12

Posted 30 May 2012 - 10:31 AM

Finally my nightmare has finished.

After days of research I found a solution: I replaced the Apache server with a Microsoft free server.

Using Microsoft Web Platform Installer 3.0 I successfully installed Webmatrix Server. It's easy to use and connect to MySQL by clicking on the icon "add connection".

I hope this help other people with this W7 problem.

And thank You again lemuel and drewdin.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users