Jump to content


Photo

Apache Doesn't Start With Easyphp


  • Please log in to reply
6 replies to this topic

#1 Nagarjun Palavalli

Nagarjun Palavalli

    New Member

  • Members
  • Pip
  • 1 posts

Posted 30 March 2010 - 12:16 AM

Hey Guys,

I purchased this book recently and love it. Everything is super simple and clearly laid out to understand. As recommended by the book, I download and installed EasyPHP to begin developing websites. However, the Apache server doesn't start. When I click 'Start', it sometimes goes to the yellow light and then immediately stops. Otherwise, it doesn't do anything. I've restarted EasyPHP and tried. I use Windows Vista. The MySQL server starts and seems to be working. Can someone please tell me what to do?

Thanks,
Nagarjun

Edited by Nagarjun Palavalli, 30 March 2010 - 12:17 AM.


#2 Robin Nixon

Robin Nixon

    Active Member

  • O'Reilly Author
  • PipPipPipPip
  • 113 posts
  • Gender:Male
  • Location:UK

Posted 30 March 2010 - 12:21 AM

Hi Nagarjun,

I have seen this before. It's likely that the correct permissions have not been set for the EasyPHP folders. To correct this, navigate to your Program Files folder, right-click on the EasyPHP 3.0 folder, and select Properties. Then from here click the Security tab followed by Edit to change the permissions for this folder and its subfolders, ensuring that all users have write access.


#3 BungleFoot

BungleFoot

    New Member

  • Members
  • Pip
  • 1 posts

Posted 23 September 2012 - 12:54 PM

On windows, I have found that the apache 2.2 distribution that comes with easyphp (and wampserver as well) requires that you install the Microsoft vc++ 2010 AND 2008 redistributables for your architecture (32or 64bit). I was attempting to install a wamp on a fresh XP install and it refused to start until I installed BOTH redistributables. The download for wampserver tells you that you need the 2010 redist package, but it doesn't tell you that you also need the 2008.

ron.

#4 flint

flint

    Active Member

  • Members
  • PipPip
  • 10 posts

Posted 24 January 2013 - 12:57 PM

It doesn't get install in my pc in any ways.

Are you using "localhost" by chance? If so, you need to substitute "127.0.0.1" for it.

#5 flint

flint

    Active Member

  • Members
  • PipPip
  • 10 posts

Posted 24 January 2013 - 04:39 PM

It doesn't get install in my pc in any ways.

Also, I found a video on YouTube "How to install EasyPHP on Windows 7" that saved the day for me.

Hope it helps.

#6 flint

flint

    Active Member

  • Members
  • PipPip
  • 10 posts

Posted 24 January 2013 - 04:47 PM

It doesn't get install in my pc in any ways.

Here's another youtube video that was very helpful in resolving my problem.

#7 nandini_36773

nandini_36773

    New Member

  • Members
  • Pip
  • 1 posts

Posted 25 November 2014 - 03:12 AM

guys i installed easyphp but apache is not starting only mysql is started and i resolved port 80 error also...

please tell me wat is the problem and how to resolve it




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users